Action Only screen is sending two requests resulting in error.

Process followed::

Every list record is having a button with name 'Delete'. In action i gave the targetscreen(say screen2) to this delete button.screen2 is action only screen with the fields to go in request. an added save menu with the target screen. When i chked this on the simulator im getting internal server error and from server logs i came to that two delete requests are sent to the server.First request is deleting the record.Second request is trying to delete the record which is already deleted by first request so im getting error responce for the second request.

Not able to figure out why two requests are going to server on single click of Delete Button.

please suggest how to resolve.  

thanks in advance,

Sirisha K

Have more questions? Submit a request

4 Comments

  • 0
    Avatar
    Sirisha Katragadda

    I didnt get what u are exactly asking for and dont know where i have to check for it :( . As far as i know we are using REST plugin in server for creating datasources. We are not facing this type of issue in any other screen. I changed the type of screen  to "Standard" from "Action" and clicked on delete button then in this screen i clicked on SAVE from Menu then only one request is sent to server and the target screen given to the save is displayed. So i think problem is only when the screen type is Action.

  • 0
    Avatar
    Sirisha Katragadda

    It would be greatly helpfull if you can give any suggestion to resolve this ASAP as i have an important deliverabel by this EOD(IST).

  • 0
    Avatar
    Sirisha Katragadda

    Can you please tell me the process to raise a Support ticket as i didn't find any relevant link in this site.

  • 0
    Avatar
    Sirisha Katragadda

    Thanks Garon Davis for your support. I got help from my friend and was able to log ticket.

Please sign in to leave a comment.
Powered by Zendesk