How to get carousel images working?

Following the little section on page 122 of the 7.3.13 developer guide I'm trying to set up an Image Carousel.  But there were some questions I had, currently all I've been able to get it to do is show the default image carousel image for each item, and display the names correctly for each item except the first one in the list(which it leaves blank).

So first question, The guide mentions that 'Image carousel also supports asynchronously loading images stored as URLs'.  But it doesn't really elaborate, I assumed I would store the URLs in a sql table and then put that in the list screen as the 'CarouselImage' field, but that doesn't seem to do anything.  Do I have to use a Browser field or something?

The second question is on getting the Title Override to also have the "1 of 20" type of title mentioned...  I used the calculation ID + 'Of 20' where ID is the name of the ID column.  But when I go to the list it seems to pick the max ID in the list, and when I have it in a screen host it always uses 1 as an ID regardless of which image I'm looking at.

 

Thanks!

Seb

Have more questions? Submit a request

4 Comments

  • 0
    Avatar
    smilliken

    Hi Seb,

    I was able to test this internally by placing the URL in the calculated data region for an image control and it worked without issue. I did have to wait while for the image to load on a simulator which maybe the case you are seeing. For your second question I am looking internally as to why the Title override is not working as I had the same problem where the ID was never changing.

     

    -Scott

  • 0
    Avatar
    Sebastian.Woodland

    Hi Scott,

    I tried putting the url in the calculated data region of an image control as you said, and actually that didn't seem to work either, did you have to add anything to the url to make that work?  Although either way I can't get an image control in a list screen as far as I know so it might be moot.

    Is it possible to accomplish this with a choice list instead rather than having the sql table? I didn't see it mentioned at all, but thought I'd ask since that would probably be the preferred method for my situation anyway.

     

    -Seb

  • 0
    Avatar
    smilliken

    Hi Seb,

     

    I am going to move this to a ticket and we can troubleshoot as to why this is not working through there.

     

    -Scott

  • 0
    Avatar
    Sebastian.Woodland

    Ok sounds good to me, thank you

Please sign in to leave a comment.
Powered by Zendesk